MT4 beta7: ウィジェット用のテンプレートは全然更新されていないっぽい

粗方 default_templates 周りの検証は終わったのウィジェットの方に手を出し始めました…が、なんかボロボロだ。新規テンプレートでのクラスが widget-hogehoge で始まっているのに対して /mt/plugins/WidgetManager/default_widgets の記載は3.3の時のまま。新規で追加されているものは別としてそのまま使うとスタイルが崩れるので注意が必要です。

まあ、そうは言っても module-hogehoge から widget-hogehoge への変更のみで hogehoge 部分の記載は変わっていないので一括で文字列変換かけちゃえばOKなんですがね。

当サイトはウィジェットによるサイドバーの構成をしているので最終的にはこちらを触ることが多くなってきます。このあたりも次回ベータ?で修正されているか注目したいところですね。(何か変更加わっているかもしれないし。)